快速解决 RequestsDependencyWarning: urllib3 (1.26.9) or chardet (3.0.4) doesn’t match a supported version!

在 Ubuntu Server 上使用 Pip3 安装 pymongo 库,在代码中 import pymongo 报错:

RequestsDependencyWarning: urllib3 (1.26.9) or chardet (3.0.4) doesn't match a supported version!
import pymongo 报错 RequestsDependencyWarning: urllib3 (1.26.9) or chardet (3.0.4) doesn't match a supported version!

很明显这是库版本不支持导致的,但是系统上安装 urllib3 和 chardet 已经是最新版本,难道我们还要将它们降级吗?

其实完全不需要,用以下两个操作即可解决:

1、安装 requests 库



pip3 install requests

2、更新 requests 库

如果已经安装 requests 的情况下仍出现这个错误,那说明 requests 版本太低,需要更新。

pip3 install --upgrade requests

更新 requests 之后再 import pymongo 就不会报错了。

猜你喜欢

留下评论

您的电子邮箱地址不会被公开。 必填项已用*标注